<!DOCTYPE html>

<html lang="en-US" prefix="og: https://ogp.me/ns#">

<head>
	<meta charset="UTF-8" />
<meta name="viewport" content="width=device-width, initial-scale=1" />
<meta name="template" content="City Sentinel Theme 1.42" />

<!-- Search Engine Optimization by Rank Math - https://s.rankmath.com/home -->
<title>10th Annual Cookies &amp; Cocktails event to support Girl Scouts set for August - The City Sentinel</title>
<meta name="description" content="By Darla Shelden, City Sentinel Reporter &nbsp;--"/>
<meta name="robots" content="follow, index, max-snippet:-1, max-video-preview:-1, max-image-preview:large"/>
<link rel="canonical" href="https://www.city-sentinel.com/2021/05/10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august/" />
<meta property="og:locale" content="en_US">
<meta property="og:type" content="article">
<meta property="og:title" content="10th Annual Cookies &amp; Cocktails event to support Girl Scouts set for August - The City Sentinel">
<meta property="og:description" content="By Darla Shelden, City Sentinel Reporter &nbsp;--">
<meta property="og:url" content="https://www.city-sentinel.com/2021/05/10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august/">
<meta property="og:site_name" content="The City Sentinel">
<meta property="article:tag" content="Camp Trivera">
<meta property="article:tag" content="Cookies &amp; Cocktails">
<meta property="article:tag" content="Girl Scouts Western Oklahoma">
<meta property="article:tag" content="The City Sentinel newspaper">
<meta property="article:section" content="Community">
<meta property="og:updated_time" content="2021-05-25T17:15:56-05:00">
<meta property="og:image" content="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png">
<meta property="og:image:secure_url" content="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png">
<meta property="og:image:width" content="1046">
<meta property="og:image:height" content="658">
<meta property="og:image:alt" content="10th Annual Cookies &#038; Cocktails event to support Girl Scouts set for August">
<meta property="og:image:type" content="image/png">
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="10th Annual Cookies &amp; Cocktails event to support Girl Scouts set for August - The City Sentinel">
<meta name="twitter:description" content="By Darla Shelden, City Sentinel Reporter &nbsp;--">
<meta name="twitter:image" content="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png">
<script type="application/ld+json" class="rank-math-schema">{"@context":"https://schema.org","@graph":[{"@type":["NewsMediaOrganization","Organization"],"@id":"https://www.city-sentinel.com/#organization","name":"The City Sentinel","url":"https://www.city-sentinel.com","logo":{"@type":"ImageObject","@id":"https://www.city-sentinel.com/#logo","url":"https://www.city-sentinel.com/wp-content/uploads/2010/10/sentinelweblogo.jpg","caption":"The City Sentinel","inLanguage":"en-US","width":"390","height":"100"}},{"@type":"WebSite","@id":"https://www.city-sentinel.com/#website","url":"https://www.city-sentinel.com","name":"The City Sentinel","publisher":{"@id":"https://www.city-sentinel.com/#organization"},"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png","url":"https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png","width":"1046","height":"658","inLanguage":"en-US"},{"@type":"Person","@id":"https://www.city-sentinel.com/author/darla-sheldon/","name":"Darla Shelden","url":"https://www.city-sentinel.com/author/darla-sheldon/","image":{"@type":"ImageObject","@id":"https://secure.gravatar.com/avatar/da082e231f52a04f9c5cf9dd7c0cb2f5?s=96&amp;d=mm&amp;r=g","url":"https://secure.gravatar.com/avatar/da082e231f52a04f9c5cf9dd7c0cb2f5?s=96&amp;d=mm&amp;r=g","caption":"Darla Shelden","inLanguage":"en-US"},"worksFor":{"@id":"https://www.city-sentinel.com/#organization"}},{"@type":"WebPage","@id":"https://www.city-sentinel.com/2021/05/10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august/#webpage","url":"https://www.city-sentinel.com/2021/05/10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august/","name":"10th Annual Cookies &amp; Cocktails event to support Girl Scouts set for August - The City Sentinel","datePublished":"2021-05-25T17:15:54-05:00","dateModified":"2021-05-25T17:15:56-05:00","author":{"@id":"https://www.city-sentinel.com/author/darla-sheldon/"},"isPartOf":{"@id":"https://www.city-sentinel.com/#website"},"primaryImageOfPage":{"@id":"https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png"},"inLanguage":"en-US"},{"@type":"BlogPosting","headline":"10th Annual Cookies &amp; Cocktails event to support Girl Scouts set for August - The City Sentinel","datePublished":"2021-05-25T17:15:54-05:00","dateModified":"2021-05-25T17:15:56-05:00","author":{"@type":"Person","name":"Darla Shelden"},"publisher":{"@id":"https://www.city-sentinel.com/#organization"},"description":"By Darla Shelden, City Sentinel Reporter &nbsp;--","name":"10th Annual Cookies &amp; Cocktails event to support Girl Scouts set for August - The City Sentinel","@id":"https://www.city-sentinel.com/2021/05/10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august/#richSnippet","isPartOf":{"@id":"https://www.city-sentinel.com/2021/05/10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august/#webpage"},"image":{"@id":"https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png"},"inLanguage":"en-US","mainEntityOfPage":{"@id":"https://www.city-sentinel.com/2021/05/10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august/#webpage"}}]}</script>
<!-- /Rank Math WordPress SEO plugin -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The City Sentinel &raquo; Feed" href="https://www.city-sentinel.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="The City Sentinel &raquo; Comments Feed" href="https://www.city-sentinel.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.city-sentinel.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.city-sentinel.com/wp-includes/css/dist/block-library/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-components-css'  href='https://www.city-sentinel.com/wp-includes/css/dist/components/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-editor-css'  href='https://www.city-sentinel.com/wp-includes/css/dist/block-editor/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-nux-css'  href='https://www.city-sentinel.com/wp-includes/css/dist/nux/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-editor-css'  href='https://www.city-sentinel.com/wp-includes/css/dist/editor/style.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='algori_pdf_viewer-cgb-style-css-css'  href='https://www.city-sentinel.com/wp-content/plugins/algori-pdf-viewer/dist/blocks.style.build.css' type='text/css' media='all' />
<link rel='stylesheet' id='wpb-google-fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans&#038;ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='weather-atlas-css'  href='https://www.city-sentinel.com/wp-content/plugins/weather-atlas/public/css/weather-atlas-public.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='weather-icons-css'  href='https://www.city-sentinel.com/wp-content/plugins/weather-atlas/public/font/weather-icons/weather-icons.min.css?ver=1.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='wpos-slick-style-css'  href='https://www.city-sentinel.com/wp-content/plugins/wp-responsive-recent-post-slider/assets/css/slick.css?ver=2.7' type='text/css' media='all' />
<link rel='stylesheet' id='wppsac-public-style-css'  href='https://www.city-sentinel.com/wp-content/plugins/wp-responsive-recent-post-slider/assets/css/recent-post-style.css?ver=2.7' type='text/css' media='all' />
<link rel='stylesheet' id='ct-mission-news-google-fonts-css'  href='//fonts.googleapis.com/css?family=Abril+Fatface%7CPT+Sans%3A400%2C700%7CPT+Serif%3A400%2C400i%2C700%2C700i&#038;subset=latin%2Clatin-ext&#038;display=swap&#038;ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='ct-mission-news-font-awesome-css'  href='https://www.city-sentinel.com/wp-content/themes/City-Sentinel-Theme/assets/font-awesome/css/all.min.css?ver=5.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='ct-mission-news-style-css'  href='https://www.city-sentinel.com/wp-content/themes/City-Sentinel-Theme/style.css?ver=5.7.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-content/plugins/weather-atlas/public/js/weather-atlas-public.min.js?ver=1.2.1' id='weather-atlas-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-content/plugins/weather-atlas/public/js/jquery-cookie.min.js?ver=1.2.1' id='jquery-cookie-js'></script>
<link rel="https://api.w.org/" href="https://www.city-sentinel.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.city-sentinel.com/wp-json/wp/v2/posts/26374" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.city-sentinel.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.city-sentinel.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.2" />
<link rel='shortlink' href='https://www.city-sentinel.com/?p=26374' />
<link rel="alternate" type="application/json+oembed" href="https://www.city-sentinel.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.city-sentinel.com%2F2021%2F05%2F10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.city-sentinel.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.city-sentinel.com%2F2021%2F05%2F10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august%2F&#038;format=xml" />
<link rel="icon" href="https://www.city-sentinel.com/wp-content/uploads/2021/02/The-City-Sentinel-Mobile-Icon@72x.png" sizes="32x32" />
<link rel="icon" href="https://www.city-sentinel.com/wp-content/uploads/2021/02/The-City-Sentinel-Mobile-Icon@72x.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://www.city-sentinel.com/wp-content/uploads/2021/02/The-City-Sentinel-Mobile-Icon@72x.png" />
<meta name="msapplication-TileImage" content="https://www.city-sentinel.com/wp-content/uploads/2021/02/The-City-Sentinel-Mobile-Icon@72x.png" />
	<link href="https://www.city-sentinel.com/wp-content/themes/City-Sentinel-Theme/assets/images/favicon.ico" rel="shortcut icon">
	<!-- Global site tag (gtag.js) - Google Analytics -->
	<script async src="https://www.googletagmanager.com/gtag/js?id=UA-142483255-58"></script>
	<script>
	  window.dataLayer = window.dataLayer || [];
	  function gtag(){dataLayer.push(arguments);}
	  gtag('js', new Date());
	
	  gtag('config', 'UA-142483255-58');
	</script>
<script async src='/cdn-cgi/bm/cv/669835187/api.js'></script></head>

<body id="City-Sentinel-Theme" class="post-template-default single single-post postid-26374 single-format-standard">
<a class="skip-content" href="#main">Press &quot;Enter&quot; to skip to content</a>
<div id="overflow-container" class="overflow-container">
	<div id="max-width" class="max-width">
							<header class="site-header" id="site-header" role="banner">
				<div class="header-image-container">
					<div class="top-nav">
						<button id="search-toggle" class="search-toggle"><i class="fas fa-search"></i><span>Search</span></button>
<div id="search-form-popup" class="search-form-popup">
	<div class="inner">
		<div class="title">Search The City Sentinel</div>
		<div class='search-form-container'>
    <form role="search" method="get" class="search-form" action="https://www.city-sentinel.com">
        <input id="search-field" type="search" class="search-field" value="" name="s"
               title="Search" placeholder=" Search for..." />
        <input type="submit" class="search-submit" value='Search'/>
    </form>
</div>		<a id="close-search" class="close" href="#"><svg xmlns="http://www.w3.org/2000/svg" width="20" height="20" viewBox="0 0 20 20" version="1.1"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-17.000000, -12.000000)" fill="#000000"><g transform="translate(17.000000, 12.000000)"><rect transform="translate(10.000000, 10.000000) rotate(45.000000) translate(-10.000000, -10.000000) " x="9" y="-2" width="2" height="24"/><rect transform="translate(10.000000, 10.000000) rotate(-45.000000) translate(-10.000000, -10.000000) " x="9" y="-2" width="2" height="24"/></g></g></g></svg></a>
	</div>
</div>
						<div id="menu-secondary-container" class="menu-secondary-container">
							<div id="menu-secondary" class="menu-container menu-secondary" role="navigation">
	<nav class="menu"><ul id="menu-secondary-items" class="menu-secondary-items"><li id="menu-item-24685" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24685"><a href="https://www.city-sentinel.com/archives/">Archives</a></li>
<li id="menu-item-24677" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24677"><a href="https://www.city-sentinel.com/about/">About</a></li>
<li id="menu-item-24675" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24675"><a href="https://www.city-sentinel.com/advertise/">Advertise</a></li>
<li id="menu-item-24676" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24676"><a href="https://www.city-sentinel.com/contact/">Contact</a></li>
<li id="menu-item-24678" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24678"><a href="https://www.city-sentinel.com/donate-2/">Donate</a></li>
</ul></nav></div>
						</div>
						<ul id='social-media-icons' class='social-media-icons'><li>					<a class="facebook" target="_blank"
					   href="https://www.facebook.com/TheCitySentinel/">
						<i class="fab fa-facebook"
						   title="facebook"></i>
					</a>
					</li></ul>					</div>
					<div id="title-container" class="title-container"><div class='site-title has-date'><a href='https://www.city-sentinel.com'>The City Sentinel</a></div><p class="tagline">News for the Heart of Oklahoma</p>					</div>
				</div>
				<p class="date">May 26, 2021</p>				<button id="toggle-navigation" class="toggle-navigation" name="toggle-navigation" aria-expanded="false">
					<span class="screen-reader-text">open menu</span>
					<svg xmlns="http://www.w3.org/2000/svg" width="24" height="18" viewBox="0 0 24 18" version="1.1"><g stroke="none" stroke-width="1" fill="none" fill-rule="evenodd"><g transform="translate(-272.000000, -21.000000)" fill="#000000"><g transform="translate(266.000000, 12.000000)"><g transform="translate(6.000000, 9.000000)"><rect class="top-bar" x="0" y="0" width="24" height="2"/><rect class="middle-bar" x="0" y="8" width="24" height="2"/><rect class="bottom-bar" x="0" y="16" width="24" height="2"/></g></g></g></g></svg>				</button>
				<div id="menu-primary-container" class="menu-primary-container tier-1">
					<div class="dropdown-navigation"><a id="back-button" class="back-button" href="#"><i class="fas fa-angle-left"></i> Back</a><span class="label"></span></div>
<div id="menu-primary" class="menu-container menu-primary" role="navigation">
    <nav class="menu"><ul id="menu-primary-items" class="menu-primary-items"><li id="menu-item-24290" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-24290"><a href="/">Home</a></li>
<li id="menu-item-24286" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-24286"><a href="https://www.city-sentinel.com/category/editorial/">Editorial</a><button class="toggle-dropdown" aria-expanded="false" name="toggle-dropdown"><span class="screen-reader-text">open menu</span><i class="fas fa-angle-right"></i></button>
<ul class="sub-menu">
	<li id="menu-item-24283" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24283"><a href="https://www.city-sentinel.com/category/letters-to-the-editor/">Letters to the Editor</a></li>
	<li id="menu-item-24291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24291"><a href="https://www.city-sentinel.com/category/columns/">Columns</a></li>
	<li id="menu-item-24293" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24293"><a href="https://www.city-sentinel.com/category/opinion/">Opinion</a></li>
	<li id="menu-item-24292" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24292"><a href="https://www.city-sentinel.com/category/commentary/">Commentary</a></li>
</ul>
</li>
<li id="menu-item-24287" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24287"><a href="https://www.city-sentinel.com/category/education/">Education</a></li>
<li id="menu-item-24285" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-24285"><a href="https://www.city-sentinel.com/category/community/">Community</a></li>
<li id="menu-item-24289" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24289"><a href="https://www.city-sentinel.com/category/criminal-justice/">Criminal Justice</a></li>
<li id="menu-item-24288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24288"><a href="https://www.city-sentinel.com/category/government/">Government</a></li>
<li id="menu-item-24284" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24284"><a href="https://www.city-sentinel.com/category/arts-entertainment/">Arts &amp; Entertainment</a></li>
<li id="menu-item-24721" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-24721"><a href="#">Other</a><button class="toggle-dropdown" aria-expanded="false" name="toggle-dropdown"><span class="screen-reader-text">open menu</span><i class="fas fa-angle-right"></i></button>
<ul class="sub-menu">
	<li id="menu-item-24295" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24295"><a href="https://www.city-sentinel.com/category/business/">Business</a></li>
	<li id="menu-item-24296" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24296"><a href="https://www.city-sentinel.com/category/faith/">Faith</a></li>
	<li id="menu-item-24298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24298"><a href="https://www.city-sentinel.com/category/sports/">Sports</a></li>
	<li id="menu-item-24297" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-24297"><a href="https://www.city-sentinel.com/category/health/">Health</a></li>
</ul>
</li>
</ul></nav></div>
				</div>
			</header>
										<div class="content-container">
						<div class="layout-container">
				    <aside class="sidebar sidebar-left" id="sidebar-left" role="complementary">
        <div class="inner">
            <section id="text-3" class="widget widget_text"><h2 class="widget-title">Front Page</h2>			<div class="textwidget"></div>
		</section><section id="ct_mission_news_post_list-3" class="widget widget_ct_mission_news_post_list"><div class="style-1"><ul><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/good-news-and-bad-news-on-managed-care-a-commentary/">Good news and bad news on Managed Care: A Commentary<img width="239" height="300" src="https://www.city-sentinel.com/wp-content/uploads/2020/09/PatMcGByRachelMcGAug2020-239x300.jpg" class="attachment-medium size-medium wp-post-image" alt="PatMcGByRachelMcGAug2020" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2020/09/PatMcGByRachelMcGAug2020-239x300.jpg 239w, https://www.city-sentinel.com/wp-content/uploads/2020/09/PatMcGByRachelMcGAug2020.jpg 509w" sizes="(max-width: 239px) 100vw, 239px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/good-news-and-bad-news-on-managed-care-a-commentary/" class="title">Good news and bad news on Managed Care: A Commentary</a><div class="post-byline">By Patrick B. McGuigan</div></div></div><div class="bottom"><div class="excerpt">Patrick B. McGuigan, Special to The Southwest Ledger Hopes for a fully operational Managed Care system for implementation of Medicaid Expansion in Oklahoma probably ended...</div><span class="comments-link">
	<a href="https://www.city-sentinel.com/2021/05/good-news-and-bad-news-on-managed-care-a-commentary/#respond">
	<i class="far fa-comment" title="comment icon"></i>
		Comments closed	</a>
</span></div></li><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/festival-highlighting-benefits-of-composting-set-for-may-22/">Festival highlighting benefits of composting set for May 22<img width="300" height="154" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CompostingFestival-Photo3-300x154.jpg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CompostingFestival-Photo3-300x154.jpg 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CompostingFestival-Photo3-1024x524.jpg 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CompostingFestival-Photo3-768x393.jpg 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CompostingFestival-Photo3-1536x786.jpg 1536w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CompostingFestival-Photo3-2048x1049.jpg 2048w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/festival-highlighting-benefits-of-composting-set-for-may-22/" class="title">Festival highlighting benefits of composting set for May 22</a><div class="post-byline">By Darla Shelden</div></div></div><div class="bottom"><div class="excerpt">Darla Shelden, City Sentinel Reporter OKLAHOMA CITY – Oklahoma residents will have an opportunity to learn about the benefits of composting at the upcoming Compost...</div><span class="comments-link">
	<a href="https://www.city-sentinel.com/2021/05/festival-highlighting-benefits-of-composting-set-for-may-22/#respond">
	<i class="far fa-comment" title="comment icon"></i>
		Comments closed	</a>
</span></div></li><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/oklahoma-democratic-party-state-convention-to-feature-keynote-speaker-congresswoman-stacey-plaskett/">Oklahoma Democratic Party State Convention to feature keynote speaker Congresswoman Stacey Plaskett<img width="300" height="165" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-ODPConvention-Photo2-300x165.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-ODPConvention-Photo2-300x165.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-ODPConvention-Photo2-1024x564.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-ODPConvention-Photo2-768x423.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-ODPConvention-Photo2-1536x846.png 1536w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-ODPConvention-Photo2.png 1700w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/oklahoma-democratic-party-state-convention-to-feature-keynote-speaker-congresswoman-stacey-plaskett/" class="title">Oklahoma Democratic Party State Convention to feature keynote speaker Congresswoman Stacey Plaskett</a><div class="post-byline">By Darla Shelden</div></div></div><div class="bottom"><div class="excerpt">By Darla Shelden, City Sentinel Reporter -- OKLAHOMA CITY – The Oklahoma Democratic Party (ODP) has announced that they will host their 2021 State Convention...</div><span class="comments-link">
	<a href="https://www.city-sentinel.com/2021/05/oklahoma-democratic-party-state-convention-to-feature-keynote-speaker-congresswoman-stacey-plaskett/#respond">
	<i class="far fa-comment" title="comment icon"></i>
		Comments closed	</a>
</span></div></li><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/oklahoma-house-of-representatives-passes-resolution-supporting-israel/">Oklahoma House of Representatives Passes Resolution Supporting Israel<img width="300" height="200" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/Oklahoma-flag-300x200.jpg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/Oklahoma-flag-300x200.jpg 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/Oklahoma-flag.jpg 600w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/oklahoma-house-of-representatives-passes-resolution-supporting-israel/" class="title">Oklahoma House of Representatives Passes Resolution Supporting Israel</a><div class="post-byline">By Staff Report</div></div></div><div class="bottom"><div class="excerpt">Staff Report OKLAHOMA CITY – The House of Representatives today adopted a resolution stating members’ support of Israel. House Resolution 1037 is authored by Rep.&nbsp;Mark...</div><span class="comments-link">
	<a href="https://www.city-sentinel.com/2021/05/oklahoma-house-of-representatives-passes-resolution-supporting-israel/#respond">
	<i class="far fa-comment" title="comment icon"></i>
		Comments closed	</a>
</span></div></li><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/contributions-to-ok-stable-can-now-help-you-save-on-oklahoma-taxes/">Contributions to OK STABLE can NOW help you save on Oklahoma taxes<img width="300" height="267" src="https://www.city-sentinel.com/wp-content/uploads/2021/03/EllynHefnerHeadshot-300x267.jpeg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/03/EllynHefnerHeadshot-300x267.jpeg 300w, https://www.city-sentinel.com/wp-content/uploads/2021/03/EllynHefnerHeadshot.jpeg 467w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/contributions-to-ok-stable-can-now-help-you-save-on-oklahoma-taxes/" class="title">Contributions to OK STABLE can NOW help you save on Oklahoma taxes</a><div class="post-byline">By Guest Commentary</div></div></div><div class="bottom"><div class="excerpt">Ellyn Hefner - The City Sentinel series on OK STABLE&nbsp;Oklahoma City&nbsp;And now OK STABLE has equal tax benefits to an Oklahoma college savings account... and...</div><span class="comments-link">
	<a href="https://www.city-sentinel.com/2021/05/contributions-to-ok-stable-can-now-help-you-save-on-oklahoma-taxes/#respond">
	<i class="far fa-comment" title="comment icon"></i>
		Comments closed	</a>
</span></div></li></ul></div></section>        </div>
    </aside>
				<section id="main" class="main" role="main">
						<aside id="above-main" class="widget-area widget-area-above-main active-1"  role="complementary">
		<section id="text-2" class="widget widget_text">			<div class="textwidget">		<div class="wppsac-slick-slider-wrp wppsac-clearfix ">
			<div id="wppsac-post-slider-1" class="wppsac-post-slider-init wppsac-post-slider design-3">
				
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/may-27-book-event-for-dr-nyla-khans-educational-strategies-for-youth-empowerment-spurs-reflections-on-possibilities/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/05/nyla-horz.png" alt="May 27 book event for Dr. Nyla Khan’s “Educational Strategies for Youth Empowerment’ spurs reflections on possibilities" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/arts-entertainment/" rel="category"> Arts &amp; Entertainment </a></li><li><a href="https://www.city-sentinel.com/category/business/" rel="category"> Business </a></li><li><a href="https://www.city-sentinel.com/category/commentary/" rel="category"> Commentary </a></li><li><a href="https://www.city-sentinel.com/category/education/" rel="category"> Education </a></li><li><a href="https://www.city-sentinel.com/category/health/" rel="category"> Health </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/may-27-book-event-for-dr-nyla-khans-educational-strategies-for-youth-empowerment-spurs-reflections-on-possibilities/">May 27 book event for Dr. Nyla Khan’s “Educational Strategies for Youth Empowerment’ spurs reflections on possibilities</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Patrick B. McGuigan</span>
					&nbsp;/&nbsp;May 25, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">Patrick B. McGuigan, The City Sentinel To celebrate the formal release of Dr. Nyla Ali Khan’s newest book, a SPECIAL...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/may-27-book-event-for-dr-nyla-khans-educational-strategies-for-youth-empowerment-spurs-reflections-on-possibilities/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/robot-stands-in-for-oklahoma-childrens-hospital-patient-jazmin-medina-during-putnam-city-west-graduation/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1.png" alt="Robot “stands in” for Oklahoma Children’s Hospital patient Jazmin Medina during Putnam City West graduation" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/community/" rel="category"> Community </a></li><li><a href="https://www.city-sentinel.com/category/health/" rel="category"> Health </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/robot-stands-in-for-oklahoma-childrens-hospital-patient-jazmin-medina-during-putnam-city-west-graduation/">Robot “stands in” for Oklahoma Children’s Hospital patient Jazmin Medina during Putnam City West graduation</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Darla Shelden</span>
					&nbsp;/&nbsp;May 25, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">By Darla Shelden, City Sentinel Reporter -- OKLAHOMA CITY – Oklahoma City resident Jazmin Medina graduated from Putnam City West...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/robot-stands-in-for-oklahoma-childrens-hospital-patient-jazmin-medina-during-putnam-city-west-graduation/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/representative-cyndi-munson-will-be-oklahoma-house-democratic-caucus-leader-after-november-2022-election/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/05/munson.png" alt="Representative Cyndi Munson will be Oklahoma House Democratic Caucus leader after November 2022 election" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/community/" rel="category"> Community </a></li><li><a href="https://www.city-sentinel.com/category/government/" rel="category"> Government </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/representative-cyndi-munson-will-be-oklahoma-house-democratic-caucus-leader-after-november-2022-election/">Representative Cyndi Munson will be Oklahoma House Democratic Caucus leader after November 2022 election</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Staff Report</span>
					&nbsp;/&nbsp;May 24, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">The City Sentinel, Staff Report&nbsp; OKLAHOMA CITY – State Representative Cyndi Munson, D-Oklahoma City, has been elected to serve as...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/representative-cyndi-munson-will-be-oklahoma-house-democratic-caucus-leader-after-november-2022-election/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/millions-in-mcgirt-legal-costs-expected/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/05/Wallace-Bell-and-Virgin.png" alt="Millions in ‘McGirt’ legal costs expected" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/business/" rel="category"> Business </a></li><li><a href="https://www.city-sentinel.com/category/criminal-justice/" rel="category"> Criminal Justice </a></li><li><a href="https://www.city-sentinel.com/category/government/" rel="category"> Government </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/millions-in-mcgirt-legal-costs-expected/">Millions in ‘McGirt’ legal costs expected</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Darla Shelden</span>
					&nbsp;/&nbsp;May 22, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">Ray Carter, Center for Independent Journalism&nbsp; The fallout from a U.S. Supreme Court ruling that declared a tribal reservation was...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/millions-in-mcgirt-legal-costs-expected/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/festival-highlighting-benefits-of-composting-set-for-may-22/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CompostingFestival-Photo3.jpg" alt="Festival highlighting benefits of composting set for May 22" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/front-page/" rel="category"> Front Page </a></li><li><a href="https://www.city-sentinel.com/category/health/" rel="category"> Health </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/festival-highlighting-benefits-of-composting-set-for-may-22/">Festival highlighting benefits of composting set for May 22</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Darla Shelden</span>
					&nbsp;/&nbsp;May 20, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">Darla Shelden, City Sentinel Reporter OKLAHOMA CITY – Oklahoma residents will have an opportunity to learn about the benefits of...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/festival-highlighting-benefits-of-composting-set-for-may-22/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/bobby-stem-stars-in-fast-money-new-video-release-and-campaign-from-the-oklahoma-association-of-general-contractors/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/05/AOGC-Fast-Money-Postcard.jpg" alt="Bobby Stem stars in ‘Fast Money’ – new video release and campaign from the Oklahoma Association of General Contractors" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/arts-entertainment/" rel="category"> Arts &amp; Entertainment </a></li><li><a href="https://www.city-sentinel.com/category/business/" rel="category"> Business </a></li><li><a href="https://www.city-sentinel.com/category/community/" rel="category"> Community </a></li><li><a href="https://www.city-sentinel.com/category/government/" rel="category"> Government </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/bobby-stem-stars-in-fast-money-new-video-release-and-campaign-from-the-oklahoma-association-of-general-contractors/">Bobby Stem stars in ‘Fast Money’ – new video release and campaign from the Oklahoma Association of General Contractors</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Patrick B. McGuigan</span>
					&nbsp;/&nbsp;May 19, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">Patrick B. McGuigan, The City Sentinel OKLAHOMA CITY – Just when you thought everything was gloom and doom … it’s...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/bobby-stem-stars-in-fast-money-new-video-release-and-campaign-from-the-oklahoma-association-of-general-contractors/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/greenwood-bitter-root-comic-series-panel-discussion-to-commemorate-tulsa-race-massacre-centennial/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-Greenville-Photo1.jpg" alt="Greenwood “Bitter Root” comic series panel discussion to commemorate Tulsa Race Massacre centennial" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/community/" rel="category"> Community </a></li><li><a href="https://www.city-sentinel.com/category/arts-entertainment/" rel="category"> Arts &amp; Entertainment </a></li><li><a href="https://www.city-sentinel.com/category/criminal-justice/" rel="category"> Criminal Justice </a></li><li><a href="https://www.city-sentinel.com/category/education/" rel="category"> Education </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/greenwood-bitter-root-comic-series-panel-discussion-to-commemorate-tulsa-race-massacre-centennial/">Greenwood “Bitter Root” comic series panel discussion to commemorate Tulsa Race Massacre centennial</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Darla Shelden</span>
					&nbsp;/&nbsp;May 17, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">By Darla Shelden, City Sentinel Reporter OKLAHOMA CITY — To commemorate the 100th Anniversary of the Tulsa Race Massacre, The...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/greenwood-bitter-root-comic-series-panel-discussion-to-commemorate-tulsa-race-massacre-centennial/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/oklahoma-talent-marilyn-artus-her-flag-project-to-be-featured-at-national-museum-of-women-in-the-arts/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-HerFlag-Photo1.png" alt="Oklahoma talent Marilyn Artus’ Her Flag project to be featured at National Museum of Women in the Arts" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/arts-entertainment/" rel="category"> Arts &amp; Entertainment </a></li><li><a href="https://www.city-sentinel.com/category/community/" rel="category"> Community </a></li><li><a href="https://www.city-sentinel.com/category/education/" rel="category"> Education </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/oklahoma-talent-marilyn-artus-her-flag-project-to-be-featured-at-national-museum-of-women-in-the-arts/">Oklahoma talent Marilyn Artus’ Her Flag project to be featured at National Museum of Women in the Arts</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Darla Shelden</span>
					&nbsp;/&nbsp;May 17, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">By Darla Shelden, City Sentinel Reporter -- OKLAHOMA CITY - The National Museum of Women in the Arts has partnered...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/oklahoma-talent-marilyn-artus-her-flag-project-to-be-featured-at-national-museum-of-women-in-the-arts/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/contributions-to-ok-stable-can-now-help-you-save-on-oklahoma-taxes/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/03/EllynHefnerHeadshot.jpeg" alt="Contributions to OK STABLE can NOW help you save on Oklahoma taxes" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/uncategorized/" rel="category"> Uncategorized </a></li><li><a href="https://www.city-sentinel.com/category/front-page/" rel="category"> Front Page </a></li><li><a href="https://www.city-sentinel.com/category/government/" rel="category"> Government </a></li><li><a href="https://www.city-sentinel.com/category/health/" rel="category"> Health </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/contributions-to-ok-stable-can-now-help-you-save-on-oklahoma-taxes/">Contributions to OK STABLE can NOW help you save on Oklahoma taxes</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Guest Commentary</span>
					&nbsp;/&nbsp;May 14, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">Ellyn Hefner - The City Sentinel series on OK STABLE&nbsp;Oklahoma City&nbsp;And now OK STABLE has equal tax benefits to an...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/contributions-to-ok-stable-can-now-help-you-save-on-oklahoma-taxes/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>
<div class="wppsac-post-slides">
	<div class="wppsac-post-overlay">
		<div class="wppsac-post-image-bg">
			<a href="https://www.city-sentinel.com/2021/05/metro-library-system-connects-with-sister-library-in-dusseldorf-germany-and-offers-sit-stay-service/">
									<img  src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-MetroLibrary-Photo1..jpg" alt="Metro Library System connects with Sister Library in Düsseldorf, Germany and offers Sit &#038; Stay service" />
							</a>
		</div>
					<div class="wppsac-post-categories"><ul class="wppsac-post-categories-list"><li><a href="https://www.city-sentinel.com/category/community/" rel="category"> Community </a></li><li><a href="https://www.city-sentinel.com/category/education/" rel="category"> Education </a></li><li><a href="https://www.city-sentinel.com/category/top-news/" rel="category"> Top News </a></li></ul></div>
				<div class="wppsac-post-short-content">
			<div class="wppsac-item-meta bottom">
			  	<h2 class="wppsac-post-title">
					<a href="https://www.city-sentinel.com/2021/05/metro-library-system-connects-with-sister-library-in-dusseldorf-germany-and-offers-sit-stay-service/">Metro Library System connects with Sister Library in Düsseldorf, Germany and offers Sit &#038; Stay service</a>
				</h2>
								<div class="wppsac-post-date">
					 
						<span>By Darla Shelden</span>
					&nbsp;/&nbsp;May 13, 2021				</div>
				
								<div class="wppsac-post-content">
											<div class="wppsac-sub-content">By Darla Shelden, City Sentinel Reporter -- OKLAHOMA CITY&nbsp;—&nbsp;Metropolitan Library System customers will get a&nbsp;virtual look into the history and...</div>
					
											<a class="wppsac-readmorebtn" href="https://www.city-sentinel.com/2021/05/metro-library-system-connects-with-sister-library-in-dusseldorf-germany-and-offers-sit-stay-service/">Read More</a>
									</div>
							</div>
		</div>
	</div>
</div>			</div>
			<div class="wppsac-slider-conf wppsac-hide" data-conf="{&quot;dots&quot;:&quot;true&quot;,&quot;arrows&quot;:&quot;true&quot;,&quot;autoplay&quot;:&quot;true&quot;,&quot;autoplay_interval&quot;:3000,&quot;speed&quot;:500,&quot;rtl&quot;:&quot;false&quot;,&quot;lazyload&quot;:&quot;&quot;}"></div>
		</div>
	
</div>
		</section>	</aside>

<div id="loop-container" class="loop-container">
    <div class="post-26374 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-education tag-camp-trivera tag-cookies-cocktails tag-girl-scouts-western-oklahoma tag-the-city-sentinel-newspaper entry">
		<article>
		<div class="featured-image"><img width="1046" height="658" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png" class="attachment-full size-full wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png 1046w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1-300x189.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1-1024x644.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1-768x483.png 768w" sizes="(max-width: 1046px) 100vw, 1046px" /></div>		<div class='post-header'>
			<h1 class='post-title'>10th Annual Cookies &#038; Cocktails event to support Girl Scouts set for August</h1>
			<div class="post-byline">By Darla Shelden on May 25, 2021</div>		</div>
				<div class="post-content">
					
<p>By Darla Shelden, City Sentinel Reporter &nbsp;&#8212;</p>



<p>OKLAHOMA CITY &#8212; A menu created by local restaurants using Girl Scout Cookies will be the focus of the 10th Annual Cookies &amp; Cocktails fundraiser scheduled for Friday, August 13. The event will take place from 5:30 to 8:30 p.m.at <a href="https://camp.gswestok.org/types-of-camp/day-camp/?gclid=Cj0KCQjwkZiFBhD9ARIsAGxFX8AwtKpN78bFavJF5KDpi0UWfXuBhSHTrxlnf7YwizzF4r4YYETiKHcaAuEmEALw_wcB" target="_blank" rel="noopener">Camp Trivera</a>, 2508 NE 50<sup>th</sup>&nbsp;Street in Oklahoma City.</p>



<p>Hosted by Girl Scouts Western Oklahoma (GSWESTOK), the evening will feature sweet and savory snacks and beverages incorporating Girl Scout Cookies as an ingredient in every item.<br><br>During the event, attendees will sample treats and vote for their favorite creations as they explore the camp.&nbsp;</p>



<p>“We are thrilled to really use Camp Trivera this year,” said Cookies and Cocktails Co-chair Leah Roper.&nbsp;“The committee has been working hard to make our 10<sup>th</sup>&nbsp;year the best yet. There will be a scavenger hunt for guests to explore the camp while eating their bites and catching up with friends.”&nbsp;</p>



<p>For the first time, Cookies and Cocktails guests will be able to stay overnight at Camp Trivera for an additional fee.<br><br>Overnight guests will be treated to a campfire and s’mores, continental breakfast and surprise activities. Prices for sleeping accommodations range from $50 for a spot on the hammock deck to $1,000 for a tree house that sleeps ten.<br><br>Options for those spending the night also include pizza, beer and wine deliveries for an additional fee.</p>



<p>“Guests can pitch a tent, sleep in the treehouses, or bunk down for the night in our themed rooms,” said Roper.&nbsp;&nbsp;<br><br>“Capacity is limited, and overnight guests must purchase a ticket to Cookies and Cocktails to be eligible to stay the night,” Roper added. “Capacity is limited, so those who want to experience the camp in this way should book now.”</p>



<p>Funds raised through Cookies and Cocktails support the GSWESTOK higher awards programming, providing resources for Girl Scouts who take the initiative to earn their Bronze, Silver and Gold Awards. Each of these awards are given to girls who identify and assist with needs in their communities, making the world a better place.&nbsp;</p>



<p>Safety precautions for the event include indoor/outdoor spaces, activities taking place around the camp, along with a mask requirement with plans to transition to a drive thru experience if necessary.&nbsp;</p>



<p>Tickets to Cookies &amp; Cocktails 2021 are available to purchase online by clicking <a href="http://weblink.donorperfect.com/cc21" target="_blank" rel="noopener">here</a>.</p>



<p>Options include&nbsp;$60 for general admission or $80 for VIP access to be the first to taste these treats.<br><br>Sponsorships are also available and start at $500, which includes two tickets for the event.&nbsp;Overnight accommodations can be reserved <a href="http://weblink.donorperfect.com/overnight21" target="_blank" rel="noopener">here</a>.</p>



<p>For more information about tickets and overnight accommodations, contact Maile Hopkins, Fund Development Manager, at 405-528-4475 or&nbsp;<a href="/cdn-cgi/l/email-protection#6a0702051a010304192a0d191d0f191e05014405180d" target="_blank" rel="noreferrer noopener"><span class="__cf_email__" data-cfemail="325f5a5d42595b5c41725541455741465d591c5d4055">[email&#160;protected]</span></a>.</p>



<p>Located in 39 Oklahoma counties in the central, southwest and northwest region of the state, Girl Scouts Western Oklahoma builds girls of courage, confidence and character.</p>



<p>Through leadership-building programs, GSWEST offers girls pathways to explore their interests such as STEM (science, technology, engineering and math), healthy lifestyles and activities like the High Adventure Team and summer camps, and community service projects through the Girl Scout <a href="https://www.girlscouts.org/en/our-program/highest-awards.html" target="_blank" rel="noopener">Bronze, Silver and Gold</a> awards.</p>



<p>For more information, visit <a href="https://www.gswestok.org/" target="_blank" rel="noopener">gswestok.org</a>.</p>



<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="722" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo2-1024x722.png" alt="" class="wp-image-26376" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo2-1024x722.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo2-300x212.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo2-768x542.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo2-1536x1083.png 1536w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo2.png 1750w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>For the first time, Cookies and Cocktails guests will be able to stay overnight at Camp Trivera for an additional fee. Image via Girl Scouts Western Oklahoma</figcaption></figure>



<figure class="wp-block-image size-large"><img loading="lazy" width="1024" height="730" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo3-1024x730.jpeg" alt="" class="wp-image-26377" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo3-1024x730.jpeg 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo3-300x214.jpeg 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo3-768x547.jpeg 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo3.jpeg 1242w" sizes="(max-width: 1024px) 100vw, 1024px" /><figcaption>Prices for sleeping accommodations at Camp Trivera range from $50 for a spot on the hammock deck to $1,000 for a tree house that sleeps ten. Image via Girl Scouts Western Oklahoma</figcaption></figure>



<figure class="wp-block-image size-large"><img loading="lazy" width="500" height="216" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo4jpeg.png" alt="" class="wp-image-26378" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo4jpeg.png 500w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo4jpeg-300x130.png 300w" sizes="(max-width: 500px) 100vw, 500px" /></figure>
								</div>
		<div class="post-meta">
			<p class="post-categories"><span>Published in</span> <a href="https://www.city-sentinel.com/category/community/" title="View all posts in Community">Community</a> and <a href="https://www.city-sentinel.com/category/education/" title="View all posts in Education">Education</a></p>			<div class="post-tags"><ul><li><a href="https://www.city-sentinel.com/tag/camp-trivera/" title="View all posts tagged Camp Trivera">Camp Trivera</a></li><li><a href="https://www.city-sentinel.com/tag/cookies-cocktails/" title="View all posts tagged Cookies &amp; Cocktails">Cookies &amp; Cocktails</a></li><li><a href="https://www.city-sentinel.com/tag/girl-scouts-western-oklahoma/" title="View all posts tagged Girl Scouts Western Oklahoma">Girl Scouts Western Oklahoma</a></li><li><a href="https://www.city-sentinel.com/tag/the-city-sentinel-newspaper/" title="View all posts tagged The City Sentinel newspaper">The City Sentinel newspaper</a></li></ul></div>						<div class="post-author">
		<div class="avatar-container">
		<img alt='Darla Shelden' src='https://secure.gravatar.com/avatar/da082e231f52a04f9c5cf9dd7c0cb2f5?s=78&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/da082e231f52a04f9c5cf9dd7c0cb2f5?s=156&#038;d=mm&#038;r=g 2x' class='avatar avatar-78 photo' height='78' width='78' loading='lazy'/>	</div>
		<div>
		<div class="author">Darla Shelden</div>
		<p></p>
			</div>
</div>		</div>
		<div class="more-from-category">
	<div class="category-container"><div class="top"><span class="section-title">More from <span>Community</span></span><a class="category-link" href="https://www.city-sentinel.com/category/community/">More posts in Community &raquo;</a></div><ul><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/robot-stands-in-for-oklahoma-childrens-hospital-patient-jazmin-medina-during-putnam-city-west-graduation/">Robot “stands in” for Oklahoma Children’s Hospital patient Jazmin Medina during Putnam City West graduation<img width="300" height="234" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1-300x234.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1-300x234.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1-1024x798.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1-768x598.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1.png 1194w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/robot-stands-in-for-oklahoma-childrens-hospital-patient-jazmin-medina-during-putnam-city-west-graduation/" class="title">Robot “stands in” for Oklahoma Children’s Hospital patient Jazmin Medina during Putnam City West graduation</a></li><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/drs-transition-to-host-13-summer-employment-skills-camps-for-students-with-disabilities/">DRS Transition to host 13 summer employment skills camps for students with disabilities<img width="300" height="300" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-300x300.jpg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-300x300.jpg 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-150x150.jpg 150w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-768x768.jpg 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1.jpg 880w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/drs-transition-to-host-13-summer-employment-skills-camps-for-students-with-disabilities/" class="title">DRS Transition to host 13 summer employment skills camps for students with disabilities</a></li><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/representative-cyndi-munson-will-be-oklahoma-house-democratic-caucus-leader-after-november-2022-election/">Representative Cyndi Munson will be Oklahoma House Democratic Caucus leader after November 2022 election<img width="300" height="264" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/munson-300x264.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/munson-300x264.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/munson-1024x900.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/munson-768x675.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/munson.png 1058w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/representative-cyndi-munson-will-be-oklahoma-house-democratic-caucus-leader-after-november-2022-election/" class="title">Representative Cyndi Munson will be Oklahoma House Democratic Caucus leader after November 2022 election</a></li><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/senator-rosino-says-new-law-will-help-eliminate-waiting-list-for-developmental-disabilities-services-prioritizes-oklahomans/">Senator Rosino says new law will help eliminate waiting list for developmental disabilities services; prioritizes Oklahomans<img width="300" height="242" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino-300x242.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino-300x242.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino-1024x827.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino-768x620.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino.png 1060w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/senator-rosino-says-new-law-will-help-eliminate-waiting-list-for-developmental-disabilities-services-prioritizes-oklahomans/" class="title">Senator Rosino says new law will help eliminate waiting list for developmental disabilities services; prioritizes Oklahomans</a></li><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/school-choice-bill-headed-to-governor-stitt/">School Choice bill headed to Governor Stitt<img width="300" height="277" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/jon-echols-horz-300x277.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/jon-echols-horz-300x277.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/jon-echols-horz-768x708.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/jon-echols-horz.png 946w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/school-choice-bill-headed-to-governor-stitt/" class="title">School Choice bill headed to Governor Stitt</a></li></ul></div><div class="category-container"><div class="top"><span class="section-title">More from <span>Education</span></span><a class="category-link" href="https://www.city-sentinel.com/category/education/">More posts in Education &raquo;</a></div><ul><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/may-27-book-event-for-dr-nyla-khans-educational-strategies-for-youth-empowerment-spurs-reflections-on-possibilities/">May 27 book event for Dr. Nyla Khan’s “Educational Strategies for Youth Empowerment’ spurs reflections on possibilities<img width="300" height="259" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/nyla-horz-300x259.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/nyla-horz-300x259.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/nyla-horz-768x662.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/nyla-horz.png 986w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/may-27-book-event-for-dr-nyla-khans-educational-strategies-for-youth-empowerment-spurs-reflections-on-possibilities/" class="title">May 27 book event for Dr. Nyla Khan’s “Educational Strategies for Youth Empowerment’ spurs reflections on possibilities</a></li><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/drs-transition-to-host-13-summer-employment-skills-camps-for-students-with-disabilities/">DRS Transition to host 13 summer employment skills camps for students with disabilities<img width="300" height="300" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-300x300.jpg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-300x300.jpg 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-150x150.jpg 150w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-768x768.jpg 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1.jpg 880w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/drs-transition-to-host-13-summer-employment-skills-camps-for-students-with-disabilities/" class="title">DRS Transition to host 13 summer employment skills camps for students with disabilities</a></li><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/school-choice-bill-headed-to-governor-stitt/">School Choice bill headed to Governor Stitt<img width="300" height="277" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/jon-echols-horz-300x277.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/jon-echols-horz-300x277.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/jon-echols-horz-768x708.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/jon-echols-horz.png 946w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/school-choice-bill-headed-to-governor-stitt/" class="title">School Choice bill headed to Governor Stitt</a></li><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/senate-leader-greg-treat-comments-on-passage-of-education-scholarship-program/">Senate leader Greg Treat comments on passage of education scholarship program<img width="300" height="249" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/greg-treat-300x249.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/greg-treat-300x249.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/greg-treat-1024x850.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/greg-treat-768x638.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/greg-treat.png 1062w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/senate-leader-greg-treat-comments-on-passage-of-education-scholarship-program/" class="title">Senate leader Greg Treat comments on passage of education scholarship program</a></li><li><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/greenwood-bitter-root-comic-series-panel-discussion-to-commemorate-tulsa-race-massacre-centennial/">Greenwood “Bitter Root” comic series panel discussion to commemorate Tulsa Race Massacre centennial<img width="300" height="184" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-Greenville-Photo1-300x184.jpg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-Greenville-Photo1-300x184.jpg 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-Greenville-Photo1.jpg 750w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><a href="https://www.city-sentinel.com/2021/05/greenwood-bitter-root-comic-series-panel-discussion-to-commemorate-tulsa-race-massacre-centennial/" class="title">Greenwood “Bitter Root” comic series panel discussion to commemorate Tulsa Race Massacre centennial</a></li></ul></div></div>	</article>
	</div></div>

</section> <!-- .main -->
	<aside class="sidebar sidebar-right" id="sidebar-right" role="complementary">
		<div class="inner">
			<section id="ct_mission_news_post_list-2" class="widget widget_ct_mission_news_post_list"><div class="style-1"><h2 class="widget-title">Community</h2><ul><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/robot-stands-in-for-oklahoma-childrens-hospital-patient-jazmin-medina-during-putnam-city-west-graduation/">Robot “stands in” for Oklahoma Children’s Hospital patient Jazmin Medina during Putnam City West graduation<img width="300" height="234" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1-300x234.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1-300x234.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1-1024x798.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1-768x598.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-OUChildrensHospital-Photo1.png 1194w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/robot-stands-in-for-oklahoma-childrens-hospital-patient-jazmin-medina-during-putnam-city-west-graduation/" class="title">Robot “stands in” for Oklahoma Children’s Hospital patient Jazmin Medina during Putnam City West graduation</a><div class="post-byline">May 25, 2021</div></div></div></li><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august/">10th Annual Cookies &#038; Cocktails event to support Girl Scouts set for August<img width="300" height="189" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1-300x189.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1-300x189.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1-1024x644.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1-768x483.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-CookiesCocktails-Photo1.png 1046w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/10th-annual-cookies-cocktails-event-to-support-girl-scouts-set-for-august/" class="title">10th Annual Cookies &#038; Cocktails event to support Girl Scouts set for August</a><div class="post-byline">May 25, 2021</div></div></div></li><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/drs-transition-to-host-13-summer-employment-skills-camps-for-students-with-disabilities/">DRS Transition to host 13 summer employment skills camps for students with disabilities<img width="300" height="300" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-300x300.jpg" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-300x300.jpg 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-150x150.jpg 150w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1-768x768.jpg 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/COM-DRSSummerCamps-Photo1.jpg 880w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/drs-transition-to-host-13-summer-employment-skills-camps-for-students-with-disabilities/" class="title">DRS Transition to host 13 summer employment skills camps for students with disabilities</a><div class="post-byline">May 24, 2021</div></div></div></li><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/representative-cyndi-munson-will-be-oklahoma-house-democratic-caucus-leader-after-november-2022-election/">Representative Cyndi Munson will be Oklahoma House Democratic Caucus leader after November 2022 election<img width="300" height="264" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/munson-300x264.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/munson-300x264.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/munson-1024x900.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/munson-768x675.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/munson.png 1058w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/representative-cyndi-munson-will-be-oklahoma-house-democratic-caucus-leader-after-november-2022-election/" class="title">Representative Cyndi Munson will be Oklahoma House Democratic Caucus leader after November 2022 election</a><div class="post-byline">May 24, 2021</div></div></div></li><li class="post-item has-image"><div class="top"><div class="featured-image"><a href="https://www.city-sentinel.com/2021/05/senator-rosino-says-new-law-will-help-eliminate-waiting-list-for-developmental-disabilities-services-prioritizes-oklahomans/">Senator Rosino says new law will help eliminate waiting list for developmental disabilities services; prioritizes Oklahomans<img width="300" height="242" src="https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino-300x242.png" class="attachment-medium size-medium wp-post-image" alt="" loading="lazy" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino-300x242.png 300w, https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino-1024x827.png 1024w, https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino-768x620.png 768w, https://www.city-sentinel.com/wp-content/uploads/2021/05/Rosino.png 1060w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div class="top-inner"><a href="https://www.city-sentinel.com/2021/05/senator-rosino-says-new-law-will-help-eliminate-waiting-list-for-developmental-disabilities-services-prioritizes-oklahomans/" class="title">Senator Rosino says new law will help eliminate waiting list for developmental disabilities services; prioritizes Oklahomans</a><div class="post-byline">May 23, 2021</div></div></div></li></ul></div></section><section id="media_image-10" class="widget widget_media_image"><h2 class="widget-title">AD</h2><a href="https://www.thepaseo.org/"><img width="264" height="264" src="https://www.city-sentinel.com/wp-content/uploads/2021/02/paseo264.png" class="image wp-image-24663  attachment-full size-full" alt="paseo" loading="lazy" style="max-width: 100%; height: auto;" srcset="https://www.city-sentinel.com/wp-content/uploads/2021/02/paseo264.png 264w, https://www.city-sentinel.com/wp-content/uploads/2021/02/paseo264-150x150.png 150w" sizes="(max-width: 264px) 100vw, 264px" /></a></section><section id="media_image-11" class="widget widget_media_image"><h2 class="widget-title">AD</h2><a href="https://www.brightmusic.org/"><img width="300" height="75" src="https://www.city-sentinel.com/wp-content/uploads/2021/02/brightmusic-logo.jpg" class="image wp-image-24655  attachment-full size-full" alt="brightmusic" loading="lazy" style="max-width: 100%; height: auto;" /></a></section><section id="media_image-7" class="widget widget_media_image"><h2 class="widget-title">AD</h2><a href="https://www.okcrep.org/"><img width="264" height="203" src="https://www.city-sentinel.com/wp-content/uploads/2021/02/okcrep264.png" class="image wp-image-24664  attachment-full size-full" alt="okcrep" loading="lazy" style="max-width: 100%; height: auto;" /></a></section><section id="weather_atlas-2" class="widget widget_weather_atlas"><h2 class="widget-title"></h2><div class='weather-atlas-wrapper' style='background:#000000;border:1px solid #000000;color:#ffffff;'><div class='weather-atlas-header' style='border-bottom:1px solid #000000'><div class='weather-atlas-header-title-wrapper'><div class='weather-atlas-header-title'>Oklahoma City</div><div class='city_selector_toggle_div autocomplete' style='display:none;'><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>/*<![CDATA[*/var weather_atlas_language = 'en';/*]]>*/</script><input class='city_name' id='city_name' name='city_name' type='text' value='' placeholder='type and select location from drop-down'></div></div><div class='city_selector_toggle'><a href='#' class='city_selector_toggle_link' style='color:#ffffff' title='Location'>&#9673;</a></div></div><div class='weather-atlas-body'><div class='current_temp'><i class='wi wi-fw wi-weather-26'></i><span class='temp'>75°</span><div class='current_text'>Cloudy</div><div class='sunrise_sunset'>6:18am<i class='wi wi-fw wi-weather-32'></i>8:36pm CDT</div></div><span class='current_text_2'>Feels like: 75<small>°F</small><br />Wind: 7<small>mph</small> SSE<br />Humidity: 81<small>%</small><br />Pressure: 30.08<small>"Hg</small><br />UV index: 3</span><div class='daily days' style='border-bottom:1px solid #000000'><span class='extended_day extended_day_1'>Thu</span><span class='extended_day extended_day_2'>Fri</span><span class='extended_day extended_day_3'>Sat</span></div><div class='daily'><span class='extended_day extended_day_1' title='Scattered Thunderstorms'>84/61<small>°F</small><br /><i class='wi wi-fw wi-weather-38'></i></span><span class='extended_day extended_day_2' title='Partly Cloudy'>73/55<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span><span class='extended_day extended_day_3' title='Partly Cloudy'>73/59<small>°F</small><br /><i class='wi wi-fw wi-weather-30'></i></span></div></div><div class='weather-atlas-footer' style='border-top:1px solid #000000'><a href='https://www.weather-us.com/en/oklahoma-usa/oklahoma-city' title='Weather Atlas - Weather forecast Oklahoma City, Oklahoma' style='color:#ffffff;' target='_blank'>Weather forecast <span class='weather-atlas-footer-block'>Oklahoma City, Oklahoma &#9656;</span></a></div></div></section>		</div>
	</aside>
</div><!-- layout-container -->
</div><!-- content-container -->

    <footer id="site-footer" class="site-footer" role="contentinfo">
                <div class="footer-title-container">
            <div class='site-title has-date'><a href='https://www.city-sentinel.com'>The City Sentinel</a></div>            <p class="footer-tagline">News for the Heart of Oklahoma</p>            <ul class='social-media-icons'><li>					<a class="facebook" target="_blank"
					   href="https://www.facebook.com/TheCitySentinel/">
						<i class="fab fa-facebook"
						   title="facebook"></i>
					</a>
					</li></ul>        </div>
        <div id="menu-footer-container" class="menu-footer-container">
            <div id="menu-footer" class="menu-container menu-footer" role="navigation">
	</div>
        </div>
                <div class="design-credit">
			<div class="copyright">
				<div class="container">
					&copy;2021 The City Sentinel. All Rights Reserved. Website developed by <a href="http://www.back40design.com/" target="_blank">Back40 Design</a>.
					<a href="/privacy-policy" class="privacy-link">Privacy Policy</a>
				</div>
			</div>
        </div>
            </footer>
</div><!-- .max-width -->
</div><!-- .overflow-container -->


<noscript>
	<style>
		.wppsac-slick-slider-wrp{display: none;}
	</style>
</noscript>

<script type='text/javascript' id='pgc-simply-gallery-plugin-lightbox-script-js-extra'>
/* <![CDATA[ */
var PGC_SGB_LIGHTBOX = {"lightboxPreset":"","postType":"post","lightboxSettigs":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-content/plugins/simply-gallery-block//plugins/pgc_sgb_lightbox.min.js?ver=2.1.2' id='pgc-simply-gallery-plugin-lightbox-script-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/jquery/ui/menu.min.js?ver=1.12.1' id='jquery-ui-menu-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/dist/vendor/wp-polyfill.min.js?ver=7.4.4' id='wp-polyfill-js'></script>
<script type='text/javascript' id='wp-polyfill-js-after'>
( 'fetch' in window ) || document.write( '<script src="https://www.city-sentinel.com/wp-includes/js/dist/vendor/wp-polyfill-fetch.min.js?ver=3.0.0"></scr' + 'ipt>' );( document.contains ) || document.write( '<script src="https://www.city-sentinel.com/wp-includes/js/dist/vendor/wp-polyfill-node-contains.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.DOMRect ) || document.write( '<script src="https://www.city-sentinel.com/wp-includes/js/dist/vendor/wp-polyfill-dom-rect.min.js?ver=3.42.0"></scr' + 'ipt>' );( window.URL && window.URL.prototype && window.URLSearchParams ) || document.write( '<script src="https://www.city-sentinel.com/wp-includes/js/dist/vendor/wp-polyfill-url.min.js?ver=3.6.4"></scr' + 'ipt>' );( window.FormData && window.FormData.prototype.keys ) || document.write( '<script src="https://www.city-sentinel.com/wp-includes/js/dist/vendor/wp-polyfill-formdata.min.js?ver=3.0.12"></scr' + 'ipt>' );( Element.prototype.matches && Element.prototype.closest ) || document.write( '<script src="https://www.city-sentinel.com/wp-includes/js/dist/vendor/wp-polyfill-element-closest.min.js?ver=2.0.2"></scr' + 'ipt>' );( 'objectFit' in document.documentElement.style ) || document.write( '<script src="https://www.city-sentinel.com/wp-includes/js/dist/vendor/wp-polyfill-object-fit.min.js?ver=2.3.4"></scr' + 'ipt>' );
</script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/dist/dom-ready.min.js?ver=eb19f7980f0268577acb5c2da5457de3' id='wp-dom-ready-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/dist/hooks.min.js?ver=50e23bed88bcb9e6e14023e9961698c1' id='wp-hooks-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/dist/i18n.min.js?ver=db9a9a37da262883343e941c3731bc67' id='wp-i18n-js'></script>
<script type='text/javascript' id='wp-i18n-js-after'>
wp.i18n.setLocaleData( { 'text direction\u0004ltr': [ 'ltr' ] } );
</script>
<script type='text/javascript' id='wp-a11y-js-translations'>
( function( domain, translations ) {
	var localeData = translations.locale_data[ domain ] || translations.locale_data.messages;
	localeData[""].domain = domain;
	wp.i18n.setLocaleData( localeData, domain );
} )( "default", { "locale_data": { "messages": { "": {} } } } );
</script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/dist/a11y.min.js?ver=5e00de7a43b31bbb9eaf685f089a3903' id='wp-a11y-js'></script>
<script type='text/javascript' id='jquery-ui-autocomplete-js-extra'>
/* <![CDATA[ */
var uiAutocompleteL10n = {"noResults":"No results found.","oneResult":"1 result found. Use up and down arrow keys to navigate.","manyResults":"%d results found. Use up and down arrow keys to navigate.","itemSelected":"Item selected."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/jquery/ui/autocomplete.min.js?ver=1.12.1' id='jquery-ui-autocomplete-js'></script>
<script type='text/javascript' id='ct-mission-news-js-js-extra'>
/* <![CDATA[ */
var mission_news_objectL10n = {"openMenu":"open menu","closeMenu":"close menu","openChildMenu":"open dropdown menu","closeChildMenu":"close dropdown menu"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-content/themes/City-Sentinel-Theme/js/build/production.min.js?ver=5.7.2' id='ct-mission-news-js-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-includes/js/wp-embed.min.js?ver=5.7.2' id='wp-embed-js'></script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-content/plugins/wp-responsive-recent-post-slider/assets/js/slick.min.js?ver=2.7' id='wpos-slick-jquery-js'></script>
<script type='text/javascript' id='wppsac-public-script-js-extra'>
/* <![CDATA[ */
var Wppsac = {"is_mobile":"0","is_rtl":"0","is_avada":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.city-sentinel.com/wp-content/plugins/wp-responsive-recent-post-slider/assets/js/wppsac-public.js?ver=2.7' id='wppsac-public-script-js'></script>

<script type="text/javascript">(function(){window['__CF$cv$params']={r:'6558ad57cca15b64',m:'96794478dd001cb68b6398bd8b2162f6c2e82526-1622049658-1800-Acllcm8RDoxf5PNn2XpZNn4G13oO08BGSEgc9QFVFShImOfptUe1+M0GdKgIZEU5IA4xOF8r50h4AQtLFXwCS1rn+V72/kftiSr7a8lgmi7+b5PYR0ZIT1jucRC+6fi9fdW4FThK4EKvtswQlPtbfjrgWGwyQJe5bbUFohBNXAXtfjcRuTdtzRSGpNecL0kajLoz1ZiBgAXfGfzIvCbYES1/Xix0wIyAmc6j4Khol8vs',s:[0x25d567c7b0,0x09a6d23a27],}})();</script></body>
</html>